You must be logged in to post messages.
Please login or register

Tech Help
Moderated by Maffia

Hop to:    
Welcome! You are not logged in. Please Login or Register.5 replies
Age of Empires III Heaven » Forums » Tech Help » Error 1603 during install
Bottom
Topic Subject:Error 1603 during install
Z1LK
Skirmisher
posted 10-27-05 04:53 PM EDT (US)         
When I pop in my disk, autoplay comes up, and after I click "install", I get this error:

1603: Error installing Windows Installer engine. A file which needs to be replaced may be held in use. Close all applications and try again.

Does anyone know how I can fix this?

AuthorReplies:
Pale Horse
Skirmisher
posted 10-27-05 05:44 PM EDT (US)     1 / 5       
Off hand, try disconnecting your network, and shutting down your antivirus programs, or disabling realtime protection, then installing.

NOOB'XPERT wannabe

[This message has been edited by Pale Horse (edited 10-27-2005 @ 05:44 PM).]

Z1LK
Skirmisher
posted 10-27-05 05:52 PM EDT (US)     2 / 5       
Nope, it's still not working.

This is a problem with the InstallShield Wizard. Is there a way I can install the game manually? And I don't know that that would even help, but it crossed my mind.

[This message has been edited by Z1LK (edited 10-27-2005 @ 05:53 PM).]

Pale Horse
Skirmisher
posted 10-27-05 11:30 PM EDT (US)     3 / 5       
Error 1603: Fatal Error During Installation
Problem

When running an installation, you receive the following error message:

"Error 1603: Fatal Error During Installation"

Or you may get the following error:

"Error 1603: General Windows Installer engine error. Increase DiskSpace requirement in Setup.ini and try again."

Fix

Error 1603 is a generic machine-specific issue. One or more of the following fixes may resolve the error.

1. This error is known to occur on computers that do not have enough disk space for the installation. To increase your hard disk space, follow the instructions in How Do I Increase Hard Disk Space on My Computer?
2. The Temp directory is not clean. To clean the Temp directory, follow the instructions in Clean the Temp Directory.
3. A certain file on the machine is locked. To fix this:
1. Close all applications running in the background.
2. Reboot your computer.
3. Run the installation again.
4. If you are using Windows 95, 98, ME, 2000, or NT, the Windows Installer Service may not be properly installed on the machine. Update the system with the latest Windows Installer Service by following the instructions in How Do I Install the Windows Installer Engine on My Computer?
5. On Windows NT, 2000, or XP, make sure you have administrative privileges. To confirm you have administrative privileges, follow the instructions in Acquire Administrative Privileges on Your Computer.
6. Use Microsoft’s Windows Installer Cleanup utility to remove traces of previous installations. This utility does not remove files installed by the installation, which may need to be removed manually. For more information, refer to Microsoft’s Knowledge Base article Description of the Windows Installer CleanUp Utility.

Additional Information

Another reason your installation may not run is changes to your computer caused by recent updates. For example, updates to your operating system may cause installations created prior to the update to fail. You may want to uninstall any recent updates, install your application, and reinstall the update. WARNING: You should check with the software vendor who created the update to ensure no adverse affects will result from uninstalling the update.
Glossary Terms

administrative privileges, Temp directory
Does Your Issue Still Exist?

If after following these instructions your product failed to install, you'll need to contact your vendor. See the Who to Contact page for more information


NOOB'XPERT wannabe
Z1LK
Skirmisher
posted 10-28-05 07:15 PM EDT (US)     4 / 5       
Thanks. It's working.
Sighman
Skirmisher
posted 10-29-05 07:00 PM EDT (US)     5 / 5       
It didnt work for me. I disabled and uninstalled my norton anit virus. I also cleared my temp folder. I also uninstalled the game completely and tried reinstalling after a reboot to no avail.

It stopped loading at Art1.bar and gave the 1603 fatal error. I tried extracting it to my art folder in the AOE3 folder. Then I loaded the excutable file. It worked perfectly until the menu; the screen was either mostly blank or completely white. I went to the graphics option and put every1 on low but that didnt change a thing.

I know that my hardware exceeds all the minimum requirement: 3500+ athlon 64, 1 gig of ram, and 128 Xpress graphics.

You must be logged in to post messages.
Please login or register

Hop to:    

Age of Empires III Heaven | HeavenGames