You must be logged in to post messages.
Please login or register

General Discussions
Moderated by Maffia, LordKivlov, JimXIX

Hop to:    
Welcome! You are not logged in. Please Login or Register.33 replies
Age of Empires III Heaven » Forums » General Discussions » The Solution to Cannot Join Game!
Bottom
Topic Subject:The Solution to Cannot Join Game!
« Previous Page  1 2  Next Page »
SmashNBash
Skirmisher
posted 07-12-07 12:12 PM EDT (US)         
I happen to know the solution to the most common problem among AoE3 players: Not being able to join games. So rejoice! *Note to mods, leave this here since most people don't bother to go to tech help. And Please Sticky

There are 10 easy steps to remedy this problem if you have a router. For the purposes of this tutorial, I will be using my WRT54. If it helps there are pictures you can use for each step. If any trouble, ask, and I will be more than happy to answer it

Most of you will be having a Linksys WRT54 router. Here is the fix to that.***NOTE, THAT ALL OTHER COMPUTERS ON THE NETWORK MUST BE OFF, TO AVOID IP CONFLICTS. If you do have problems, give the the situation and all possible details you can give me to better help you out. "It won't work" won't help me or you at all!
Steps
1. Open Network Connections. (Some of you may have to access it from the Control Panel. Now right click whatever connection it is you are using and select "Status". On the Window that opens up, select the "Support" Tab. Remember the number next to Default Gateway.Picture of this Step

2. Open up Internet Explorer and type in the number next to Default Gateway into the address bar.Picture of this Step


3. A box will open up asking for an account Name and Password. For the account name, press space once, then for the password type in admin (assuming you have never seen this screen before, or have changed the password)Picture of this Step***NOTE, IF YOU CAN'T ACCESS THIS, ASK WHOEVER SET UP THE ROUTER


4. Now, make it look like this: 2300 to 2300 TCP, and 2300 to 2310 UDP. Picture of this Step***NOTE, DON'T WORRY ABOUT PORT 80!!! JUST 2300,2300-2310.


5. Now, for each of the boxes at the end that say 192.168.*.___ where * is the number in your default gateway. In that box, type in “101” and Check the enable box for all 3. Picture of this Step


6. Click Save on the bottom of the page. Then click OK on the next page.

7. Back to the Network Connections. Open the Status box again (Refer to step 1)and leave it open, since you will be utilizing it shortly. Now Right Click the connection again, and Click on Properties. You should have a window with a list of things with a box to Check. Click on Internet Control (IP/TCP) and then Click on Properties. Picture of this Step Part 2 of this Step


8. Now in that Status box, Click on Details. In that window, you want to look at the 2 numbers next to “DNS Servers”. Leave this window open, we will come back to it. Now, back to the Internet Control Properties page. In the “IP Address” box, we will type in the number next to your Default Gateway (the 192.*.*), but this time, instead of just one digit for the last part, we will use “192.168.*.101”.Picture of this Step


9. Now, the “Subnet Mask” should fill itself in, but if not, you will have to refer to the Details part of the Status Window. Now, Under DNS Servers, you will put in those number aforementioned in Step 7.Picture of this Step


10. Now, click OK on all the Windows of the Properties, Click close in the Status Window, start up AoE3 and enjoy!


Now, for all those who run on modems, you will have to turn off all firewalls. Your McAffe, Norton, and of course, the infamous Windows Firewall. Take Windows Defender into account if you have it too.

Now good luck, and may all your games be joined!

Lolocausts are fun.

[This message has been edited by smashnbash (edited 07-13-2007 @ 10:12 AM).]

AuthorReplies:
Roark
Skirmisher
posted 07-12-07 12:18 PM EDT (US)     1 / 33       
You are assuming that everyone is at 192.168.1.101

If more than one computer is connected to the router, however, you could get assigned a different IP every time. In which case you'd have to go about setting a static IP for your computer that none others would use, (like 192.168.1.148 or something), then forwarding the ports for that IP.

ESO: Naevius
elite_zerocool
Skirmisher
posted 07-12-07 12:37 PM EDT (US)     2 / 33       
Also, different routers have different default logins; remember that when trying to access the administration console on the router.
Brtnboarder495
Skirmisher
posted 07-12-07 12:41 PM EDT (US)     3 / 33       
Yes, you two are right.

To find your computer's "Router/Internal" IP, go to:

Start->Connect To->Show All Connections/Or Select your connection from the list->Support Tab

Whatever IP is next to "IP address" is your "Router/Internal" IP. Plug that in instead of what smashnbash said.

Nice job though smash.

Gameranger: _NiGhThAwK_
SmashNBash
Skirmisher
posted 07-12-07 01:04 PM EDT (US)     4 / 33       
you guys, that is why in step 1, i tell you that you must look at the default gateway. for the purposes of this tutorial, i used 192.168.*.* where * can be any number. most people don't touch there routers though

the default gateway for me was 192.168.2.1, and that is what comes out here

some people have 153.273.2.1, but is always shown under Default Gateway

also, the reason i say ".101" is because in step 5 and step 8, those two numbers must match. that way it is guaranteed each time you can join the game. if left at "Determine IP Automatically, it might choose a different one.

to acces the page in steps 3-6, you must type in the number that is Default Gateway. Believe me, I know, I've done this many times before.
@Roark, I am not assuming, I am telling everyone to change it to that.

If you just follow the steps, nothing should go wrong

and thanks brtnboarder

Lolocausts are fun.
Brtnboarder495
Skirmisher
posted 07-12-07 01:07 PM EDT (US)     5 / 33       
Default gateway is the router's main IP address, not the individual computer's. I've port forwarded before and I know that the ports must (obviously) be routed to the computers internal IP within the router's network. So I'm pretty sure the IP address of the individual computer must be used, not the gateway.

EDIT: We're referring to step 5, not the earlier step where you type the Router's IP into your browser.

Gameranger: _NiGhThAwK_

[This message has been edited by Brtnboarder495 (edited 07-12-2007 @ 01:11 PM).]

SmashNBash
Skirmisher
posted 07-12-07 01:11 PM EDT (US)     6 / 33       
yes, but to access that page, you need to put the Default Gateway into the Internet Explorer (or any web browser). making it .101 just makes life easier

once you force it to always be .101, there shouldn't be a problem . just follow the directions and look at the pics, and you will see.

i think we misunderstood each other

Lolocausts are fun.
SUX2000
Skirmisher
posted 07-12-07 01:33 PM EDT (US)     7 / 33       
UM...

i tried this and lost all internet access XD

When I tried to put in the alternate DNS it said that the preferred and alternate DNS could not be the same. What should I do?

_____________________________\||/
______/____\_________________ /...\
______________\_____________(..__..)
______________[[_Crayola_]]>_. \___/
______________/_____.________ -||-
_____'-_______/____._.___._._.___/\
SmashNBash
Skirmisher
posted 07-12-07 01:51 PM EDT (US)     8 / 33       
^^well, you gotta put the one in the status box. All i can recommend is to try it again.

Lolocausts are fun.
MNBob
Skirmisher
posted 07-12-07 01:56 PM EDT (US)     9 / 33       
Nice write up smashnbash.

However, I'd just like to point out that it is possible to do all of these things and still have problems. For some reason AOE3 does have a problem with certain routers. Despite making this type of change with my old router (Netgear RP114) I still had occasional problems. When I replaced the router (a few months after aoe3 came out) all of my problems went away (although I still had to open the ports as smashnbash writes about).

Abus Guns and Grenadiers ARE NOT ARTILLERY!
MNBob's AOE Page
SUX2000
Skirmisher
posted 07-12-07 01:59 PM EDT (US)     10 / 33       
^^well, you gotta put the one in the status box. All i can recommend is to try it again.
could u be more specific plz -_-

_____________________________\||/
______/____\_________________ /...\
______________\_____________(..__..)
______________[[_Crayola_]]>_. \___/
______________/_____.________ -||-
_____'-_______/____._.___._._.___/\
SmashNBash
Skirmisher
posted 07-12-07 02:03 PM EDT (US)     11 / 33       
ok, take a look at Step 7 and Step 9. Try again and let me know.

Lolocausts are fun.
schildpad
Skirmisher
posted 07-12-07 02:28 PM EDT (US)     12 / 33       
1. Or you just look at portforward.com. There is everything for your specific router.

2. Often if you keep your ip on automatic, it never changes. (depends on settings of your router). Then it is not needed to put it manual

3. The first thing you always need to try is enabling UPNP.

4. NEVER disable your firewall if you run without router. If you do it behind a router you are stupid. If you do it without a router you are just retarted. I know personally that windows firewall doesnt give any problems with aoe3.

5. Do NOT disable windows defender. windows defender has nothing to do with aoe3, and there is no reason to disable it.

Summarized for those with connection problems:
1. First try enabling UPNP.
2. If that doesnt solve it, go to portforward.com and follow instructions
3. If that doesnt solve it, go to agecommunity tech support and read the FAQ
4. If that doesnt solve it, make a new topic at agecommunity tech support.

"such a kind fellow!" ~ ķįŋğ_Ćħŗĩš_ĬĬ

Furby killer should be crowned leader of AOE forum ~ [SW_GD]Teutonic

[This message has been edited by schildpad (edited 07-12-2007 @ 02:31 PM).]

SmashNBash
Skirmisher
posted 07-12-07 02:42 PM EDT (US)     13 / 33       
i did this myself, and have no problems whatsoever. i did this for people's convenience.

Lolocausts are fun.
elite_zerocool
Skirmisher
posted 07-12-07 03:01 PM EDT (US)     14 / 33       
Please, do be careful when forwarding port 80. If you have several computers hooked up to the router, and you forward port 80 to one computer, it is very possible that all other computers lose their ability to open webpages (http protocol uses port 80).
SUX2000
Skirmisher
posted 07-12-07 03:46 PM EDT (US)     15 / 33       
what is UPNP?

_____________________________\||/
______/____\_________________ /...\
______________\_____________(..__..)
______________[[_Crayola_]]>_. \___/
______________/_____.________ -||-
_____'-_______/____._.___._._.___/\
MNBob
Skirmisher
posted 07-12-07 03:56 PM EDT (US)     16 / 33       
There is absolutely no need to forward port 80 in order to make AOE3 work.

Abus Guns and Grenadiers ARE NOT ARTILLERY!
MNBob's AOE Page
SUX2000
Skirmisher
posted 07-12-07 04:04 PM EDT (US)     17 / 33       
I followed all the steps for port forwarding and port triggering with no results...

EDIT: I also have only ONE number under DNS in the stats thing and it wont let me add a second one :/

_____________________________\||/
______/____\_________________ /...\
______________\_____________(..__..)
______________[[_Crayola_]]>_. \___/
______________/_____.________ -||-
_____'-_______/____._.___._._.___/\

[This message has been edited by SUX2000 (edited 07-12-2007 @ 04:15 PM).]

schildpad
Skirmisher
posted 07-12-07 04:24 PM EDT (US)     18 / 33       
upnp is a protocol that should automatically do all the portforwarding.

In your router there somewhere should be an option to enable upnp. Which router do you have?

For example, this is at my parents router (i dont use router myself due to little difference of opinion with isp).
http://img402.imageshack.us/img402/2670/upnpay8.png

I have had router that had 5 different things for upnp you could enable, just do them all. (or post a screenshot)


This is what upnp is supposed to do: (from routers log)

It automatically forwarded the needed ports.


However from some routers it is known they cant possibly work with aoe3.

"such a kind fellow!" ~ ķįŋğ_Ćħŗĩš_ĬĬ

Furby killer should be crowned leader of AOE forum ~ [SW_GD]Teutonic

[This message has been edited by schildpad (edited 07-12-2007 @ 04:30 PM).]

SUX2000
Skirmisher
posted 07-12-07 04:46 PM EDT (US)     19 / 33       
k thx

_____________________________\||/
______/____\_________________ /...\
______________\_____________(..__..)
______________[[_Crayola_]]>_. \___/
______________/_____.________ -||-
_____'-_______/____._.___._._.___/\
cougbob
Skirmisher
posted 07-12-07 04:56 PM EDT (US)     20 / 33       
Thanks for putting this out, I will give it a try.
SUX2000
Skirmisher
posted 07-12-07 05:00 PM EDT (US)     21 / 33       
My router interface is the same as smashes(WRTg54)

I looked around for a while and found that the upnp was checked. Does upnp overide my port forward/trigger settings? Ima try unchecking it and see what happens.

_____________________________\||/
______/____\_________________ /...\
______________\_____________(..__..)
______________[[_Crayola_]]>_. \___/
______________/_____.________ -||-
_____'-_______/____._.___._._.___/\
ziGGysiGGy43
Skirmisher
posted 07-12-07 05:08 PM EDT (US)     22 / 33       
I just lost connection to everything on my main computer. I don't really have any clue how to fix it as when I try to redo the steps it says I can't connect once I put in my IP to internet explorer. Help Please.
As_Saffah
Scenario Reviewer
posted 07-12-07 06:13 PM EDT (US)     23 / 33       
Portfoward.com is okay, less chance of absolutely nixing your internet connection.

I mooch wireless off my roommate who is very hands-off about the whole thing, even forgot his wireless account password so I can't get in and make any changes, either smash's way or portforward way.

I simply go upstairs, power cycle the router and the wireless modem, hard boot my comp, and restart AOE. 80% of the time this completely resets everything so I have no problem connecting to a game right off the bat.

After the first game though, something goes wrong about half the time and I can't connect to another game unless I repeat the above steps: upstairs and downstairs. I have legs of steel from this, thank you ESO.

Someone says it has to do with a security feature in XP SP2, wherein if you have more than a certain number of remote connect attempts to your comp, it will disallow any further or close ports until you hard boot and clear the temporary record of these. This may be why torrents stop working after I've been on ESO.

Ionno, ask someone who knows more about comps than I do. But I certainly wouldn't try Smash's rawdoggin way without saving your states first, i.e. IP and DNS and subnet mask, port configuration, firewall settings, etc. so you can restore back to normal in case of internet catastrophe.

Crunkatog on ESO
Bart331 balance suggestion: aztec: remove civ
Voltiguer: Ender, Sioux in 1.04 will be a top civ, no matter how many layers of Sioux goggles you put on
schildpad on Elephants: ...their mansabdar unit sucks so hard it looks like a black hole
Crunkatog on Steam.
schildpad
Skirmisher
posted 07-13-07 02:50 AM EDT (US)     24 / 33       
@ziggy, put your ip address on automatic again. (tcp ip options, properties, etc). That should fix it.

"such a kind fellow!" ~ ķįŋğ_Ćħŗĩš_ĬĬ

Furby killer should be crowned leader of AOE forum ~ [SW_GD]Teutonic

mentork
Skirmisher
posted 07-13-07 06:13 AM EDT (US)     25 / 33       
3. A box will open up asking for an account Name and Password. For the account name, press space once, then for the password type in admin
This does not work for me, it does not let me in ;_;
« Previous Page  1 2  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Age of Empires III Heaven | HeavenGames