You must be logged in to post messages.
Please login or register

General Discussions
Moderated by Maffia, LordKivlov, JimXIX

Hop to:    
Welcome! You are not logged in. Please Login or Register.9 replies
Age of Empires III Heaven » Forums » General Discussions » Can't play TAD with TWC on Skirmish!!!
Bottom
Topic Subject:Can't play TAD with TWC on Skirmish!!!
TAKA Michinoku
Skirmisher
posted 11-11-07 09:03 AM EDT (US)         
I have both games installed but when starting either TAD or TWC I can't play with the other expansion pack civilizations (eg: Can't play Aztecs against Chinese).

Is it meant to be like that? Is there anyway to play on Skirmish?

Please help me, I'm going nuts!!!
AuthorReplies:
Crusty
Skirmisher
posted 11-19-07 01:51 AM EDT (US)     1 / 9       
YES I HAVE SAME PROBLEM!!!!

Cant play using TAD and access TWC Civs for versing or creating new HC etc....there just playin compatible???

Need some help for me and Taka please.
???
Myth_dracon
Skirmisher
posted 11-19-07 02:31 AM EDT (US)     2 / 9       
That's weird...I can play as a TWC race or TAD race against another TWC/TAD race on any TWC/TAD map with any TWC/TAD gametype. But maybe it's just cuz all my opponents have both expansions too? :S

I think it's a technical problem of some sort...
cu3hara
Skirmisher
posted 11-19-07 10:18 AM EDT (US)     3 / 9       
This sounds like an install problems. Unfortunately, the easiest way to try and fix this is to uninstall both expansions and the game, delete c:\program files\microsoft games\age of empires iii, delete or rename the aoe3 folder in your My Documents\My Games\ folder, then reinstalling vanilla and both expansions.

Alot of configuration/installation problems relate to mods and file changes--doing a really clean reinstall will fix this if that's the problem.

This has fixed problems for a couple of friends. Personally haven't had a problem--I've been able to play single-player skirmish vs comps from TAD/TWC/vanilla since the y-pack came out. I only had a couple of mods though (ekanta's ui and hotkey stuff).

cue

cue

[This message has been edited by cu3hara (edited 11-19-2007 @ 10:20 AM).]

TAKA Michinoku
Skirmisher
posted 11-22-07 12:18 PM EDT (US)     4 / 9       
I got a solution: Editing the system registry.

1)Run regedit.exe and go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Age of Empires 3 Expansion Pack 2\1.0 , right click on PID alphanumerical valor -----> Modify , then copy the number which appears there...

2)Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Age of Empires 3 Expansion Pack\1.0 , right click anywhere, New-----> Alphanumerical Valor , name it PID and paste the number which you previously had copied

3)Again, go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Age of Empires 3 Expansion Pack 2\1.0 , just that this time right click on DigitalProductID, copy all the weird text you see there... and onwards to the next, final step

4)Finally, go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Age of Empires 3 Expansion Pack\1.0 , right click anywhere, New--------> Binary Valor (or something similar), name it DigitalProductID, and paste what you had copied. Go to the Shortcut to TAD and that should do the trick.

It worked for me and I got no further problems after that.
mitslav
Skirmisher
posted 11-25-07 04:12 PM EDT (US)     5 / 9       
TAKA Michinoku
Well explain this Pleaseee!!! how I can create a PID file, with the same name of other??!!! you said "right click anywhere, New-----> Alphanumerical Valor , name it PID and paste the number which you previously had copied"

and the others files the same problem!
TAKA Michinoku
Skirmisher
posted 11-29-07 05:41 PM EDT (US)     6 / 9       
O.K. look, I'll try to explain it.

You go to Start - Run - regedit, right? Then you find the registry key(HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Age of Empires 3 Expansion Pack 2\1.0). This is where TAD is. There you'll see a key named PID. You right click on it, then you select "Modify". You'll find a number sequence. You gotta right-click copy it.

After that you go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Age of Empires 3 Expansion Pack\1.0. It's not the same folder. This is where TWC is. There you click anywhere in the window --> NEW ---> Alphanumerical valor. You gotta name it PID and click on "Modify", then you paste what you copied in the Expansion Pack 2 folder.

And after that, you go back where TAD is ("Expansion Pack 2/1.0" folder), right-click on a key named DigitalProductID, click on "Modify". You'll see a long number sequence. Copy it.

Finally, go back to where TWC is ("Expansion Pack/1.0" Folder), right-click in anywhere in the window ---> NEW ---> Binary Valor, you name it DigitalProductID and copy the long number sequence you had.

This solved my problem, you can go either to the TWC or TAD shortcut and you'll get the other expansion pack civs. I've tried this three times before like a month ago and it's still working perfectly.
Tezza_01
Skirmisher
posted 11-30-07 02:36 AM EDT (US)     7 / 9       
erm... does the match have a little war cheifs symbol next to it when its listed if it doesnt you cant use warchief civs on it. Next time guys CHECK it will help eveybody when trying to tell whats wrong.
TAKA Michinoku
Skirmisher
posted 11-30-07 09:34 AM EDT (US)     8 / 9       
Anytime it happens, I'll just do as I said above. Tried not only once before, and always worked.
mitslav
Skirmisher
posted 12-15-07 02:04 PM EDT (US)     9 / 9       
Thanks very much!
Now works perfectly!
You must be logged in to post messages.
Please login or register

Hop to:    

Age of Empires III Heaven | HeavenGames