You must be logged in to post messages.
Please login or register

Treaty Discussions

Hop to:    
Welcome! You are not logged in. Please Login or Register.17 replies
Age of Empires III Heaven » Forums » Treaty Discussions » Treaty Glitch: unable to build a Town Center
Bottom
Topic Subject:Treaty Glitch: unable to build a Town Center
kilmaim
Skirmisher
posted 07-14-07 03:12 PM EDT (US)         
Below you will see two screen shots. In the bottom screen shot, I destroyed one of my TC's to replace it in another location, but when I tried t rebuild it, I received the error noted in the screen shot: "During the treaty period, buildings may only be build close to the starting Town Centers." This happened yesterday (07/13/07).

In the top screen shot, I was trying to come up with a good layout for my TC while playing against the computer. I destroyed the starting barracks and outposts (on Texas) to make room for farms etc., and then killed "all" my TC's to reposition those as well to get the most efficient use of space. However, when I tried to rebuild "a" Town Center, I received the same error.

It seems like no one has done this or come across this problem in the past because I have never heard of this happening before. I'm just glad it was not in a real gamethat was rated! Anyway, this defintely need to be corrected. Any suggestions...

Top Screen shot
http://i53.photobucket.com/albums/g65/kilmaim/tryingtobuildatc2.jpg

Bottom Screen Shot
http://i53.photobucket.com/albums/g65/kilmaim/tryingtobuildatc.jpg
AuthorReplies:
Voltiguer
Skirmisher
posted 07-14-07 03:17 PM EDT (US)     1 / 17       
Its a known bug, but some ES employee said it wont5 be fixed because "who would be dumb enough to delete his starting TC lol".

NATron
Skirmisher
posted 07-14-07 03:27 PM EDT (US)     2 / 17       
Its a known bug, but some ES employee said it wont5 be fixed because "who would be dumb enough to delete his starting TC lol".

What bull! If there's a bug in a game, it should be fixed, no matter how useless the bug is. Sorry, bugs just annoy me... even typos.


★ ★ ★ ★ ★

I heard distant forests all the time - CunniJA
I found my Jabra!

[This message has been edited by Natron (edited 07-14-2007 @ 03:28 PM).]

Red Coat_monkey
Skirmisher
posted 07-14-07 05:10 PM EDT (US)     3 / 17       
its not really a bug if you delete it then you have no starting town center and you cannot build. otherwise you'd be able 2 move your base whereever and whenever you like.

However my mate did this in a RATED match and that messed up our whole game so we had to resign that was very annoyin espcially as he did it bout 25-30 mins grrr.
AI Guy
Skirmisher
posted 07-14-07 05:21 PM EDT (US)     4 / 17       
I was playing a compstomp with 4 other people once on plymouth. It was treaty 40. I tried deleting my tc and going to the island. Well now I can't build another tc. But I COULD build docks for some unknown reason so I walled off my island with docks. Then I went to wall off everyone else's tc for no reason. They deleted their tcs and eventually there was only one person left with a starting tc. We all went to her base aaaand then my comp crashed. Anyway, I think this should be fixed because sometimes you delete a tc just to reposition and you don't know it was your starting one.

___________
[aizone.uni.cc] - Never gonna get updated in your life
SahintheFalcon
Skirmisher
posted 07-14-07 08:09 PM EDT (US)     5 / 17       
It's not a bug. It's meant to be that way. Otherwise then a person could just move their TC anywhere they wanted. For example:

In an NR 40 game, a guy has everything researched and a full econ by the 30th minute. He's bored, so he deletes his original TC and puts it in the middle of the map, near the closest enemy units. The radius around which you can construct buildings has now changed. He then places his fort next to the enemy army and builds towers around the enemy mills/plantations.

Now that's something we want to avoid, isn't it? The ES employee was too lazy to explain to you why (typical of ES).

ESO Nickname: Eisenhower
Favorite Age 3 character: Sahin the Falcon
Unban James Lock!
As_Saffah
Scenario Reviewer
posted 07-14-07 09:09 PM EDT (US)     6 / 17       
You can tell which TC is your first. Just press "t" and it will take you to your first TC.

And I can understand the rationale for not allowing people to rebuild their first TC somewhere more pernicious. I would be wary of deleting it for fear of not being able to build any more buildings of any type.

Crunkatog on ESO
Bart331 balance suggestion: aztec: remove civ
Voltiguer: Ender, Sioux in 1.04 will be a top civ, no matter how many layers of Sioux goggles you put on
schildpad on Elephants: ...their mansabdar unit sucks so hard it looks like a black hole
Crunkatog on Steam.
schildpad
Skirmisher
posted 07-15-07 07:11 AM EDT (US)     7 / 17       
Like said, it is not a bug. Just dont delete your TC. (the entire idea of deleting your tc is retarded).

"such a kind fellow!" ~ ķįŋğ_Ćħŗĩš_ĬĬ

Furby killer should be crowned leader of AOE forum ~ [SW_GD]Teutonic

Zongo
Skirmisher
posted 07-15-07 08:20 AM EDT (US)     8 / 17       
omg, treaty vs AI
j/k

if it's a bug, they should fix it, but depending on the priority list, it could take *a while*

Old Indian: Once upon a time, a woman was picking up firewood. She came upon a poisonous snake frozen in the snow. She took the snake home and nursed it back to health. One day the snake bit her on the cheek. As she lay dying, she asked the snake, "Why have you done this to me?" And the snake answered, "Look, bitch, you knew I was a snake."
kilmaim
Skirmisher
posted 07-15-07 10:02 AM EDT (US)     9 / 17       
Thanks for all the input! Anyway, here is the cruxt of our situation: in nomad treaty, zones are not established until you plop down your starting TC. In regular treaty, zones are "pre-estalished".

This is the glitch: zones are established when the first TC is setup; so, even if you destroy all your TC's, "your" treaty zone is set (practically) in stone! Thus, just because you destroy/delete your TC doesn't mean you can get up and make a new zone because the treaty zone becomes established the moment the starting TC's is built. The problem is that the zone doesn't allow for you to re-create "any" TC that you destroy in your own zone - and that's a problem! You can delete/destroy any other building, but not a TC.

If the zone is set, you should be able to delete and rebuild to your hearts content, as long as its within your own zone. This is why it is a glitch and needs to be corrected.

Thanks!
schildpad
Skirmisher
posted 07-15-07 10:10 AM EDT (US)     10 / 17       
It is not a glitch, it does exactly what it says it does. And it will not be corrected. I think they just programmed something similar to no build zone near starting TC of enemy. That also doesnt stay if tc is destroyed. It is probably much work to reprogram everything because some people like to destroy their own tc...

"such a kind fellow!" ~ ķįŋğ_Ćħŗĩš_ĬĬ

Furby killer should be crowned leader of AOE forum ~ [SW_GD]Teutonic

Hockeystar
Skirmisher
posted 07-15-07 10:50 AM EDT (US)     11 / 17       
Quote from Wibble:


  • NEW BUG TO REPORT - DELETING YOUR TC IN TREATY SCREWS YOU! - By design: Workaround: 1.) DONT DELETE YOUR TC or 2.) DONT DELETE YOUR TC *AFTER* THE DIALOG PROMPTS YOU TO MAKE SURE IF YOU WANT TO DELETE IT

    TBH, I really don't know why people even bring this up as a "bug". I fail to see how deleting your TC in a treaty game is any more / less worse than deleting your TC in a non-treaty game. You're pretty screwed both ways.

    Why would people delete their own TC in the first place?

    http://agesanctuary.com/index.php?portal=TWC&fview=7&showtopic=73438&st=700
  • LordKivlov
    Royal Guard
    posted 07-15-07 04:02 PM EDT (US)     12 / 17       
    It's there to prevent people from cheating! And punish people that are silly enough to delete a TC.

    Proud Citizen of Sovietcanuckistan
    kilmaim
    Skirmisher
    posted 07-15-07 06:08 PM EDT (US)     13 / 17       
    OK...well now there seems to be another problem with destroying TC's; In the screen shot provided, I killed one of my TC's so I could wall up on the inside of my base behind my houses; After killing the TC, I had to kill a farm that was also in the way; short story: I couldn't rebuild the farm anywhere or any other building!

    This is defintely a problem! It's aglitch! If it wasn't there wouldn't be a work around. And here's why someone might delete a town center. Efficient placement of buidlings!

    http://i53.photobucket.com/albums/g65/kilmaim/TreatyProblem3.jpg"
    Brtnboarder495
    Skirmisher
    posted 07-15-07 07:10 PM EDT (US)     14 / 17       
    I agree with Wibble, if you proceed to click yes after the window comes up then your doing it intentionally. This would only mean you are trying to 'cheat' the barrier and move your TC to capture more land.

    Gameranger: _NiGhThAwK_
    Qazitory
    HG Alumnus
    posted 07-16-07 02:12 AM EDT (US)     15 / 17       
    Moving to treaty discussion, even though the question has been pretty much answered

    •Qazitory•
    •AoE3 rating: Qazitory
    My AoE3:TWC mods: QazUI - Treasure - Main Menu - Low Lag HC - Deck selection•
    •Guide my keystrokes, keep my programs alive, protect me from viruses, back up my drive.•
    kilmaim
    Skirmisher
    posted 07-16-07 06:51 PM EDT (US)     16 / 17       
    Btrnboarder,

    How can you consider repositioning your buildings as cheating? I can see if someone actually deleted their TC and then tried to rebuild it by the opponent like we used to do in AOE and AOC (but this was perfectly legit), as it is in non-treaty games (you just can't put it tight next to it (like we used to be able to do).

    Anwyway, the whole point is simply repositioning the building within the framework of one's own zone - not outside that zone,as you can see from the screen shots.

    Either way, the fact that when you delete a TC and then try to "build" another building, such as a farm, and the same error pops up, then there is defintely a glitch!

    And dude, the fix is merely a few lines of code...
    mikeychowster
    Skirmisher
    posted 07-22-07 07:03 PM EDT (US)     17 / 17       
    what if a stupid trade route is in the way of your tc and you cant build a wall around your tc because of the trade route so what do you do then? have an opening in your wall by your tc?... but its first better to build 2 other tc before deleting your original one

    [This message has been edited by mikeychowster (edited 07-22-2007 @ 07:07 PM).]

    You must be logged in to post messages.
    Please login or register

    Hop to:    

    Age of Empires III Heaven | HeavenGames