You must be logged in to post messages.
Please login or register

General Discussions
Moderated by Maffia, LordKivlov, JimXIX

Hop to:    
Welcome! You are not logged in. Please Login or Register.243 replies
Age of Empires III Heaven » Forums » General Discussions » Windows 2000
Bottom
Topic Subject:Windows 2000
« Previous Page  1 ··· 7 8 9 10  Next Page »
Ykkrosh
Skirmisher
posted 09-07-05 07:03 PM EDT (US)         
"Age of Empires III Trial requires Windows XP or later" - well, okay, except it's lying.

I use Windows 2000, so the installer refuses to run - but I can install on a spare machine that's running XP, then copy the installed files, and it appears to work perfectly well on 2K.

As far as I can see, there's no reason why the installer should be telling me to upgrade. An updated version of the demo, without this bug, would be appreciated. I shouldn't have to mess around so much just to run a game, and if it's not fixed in the retail version, ES has lost at least one sale.


Update: If you have encountered this problem, see post #111 for a way to install the game.

[This message has been edited by Ykkrosh (edited 09-09-2005 @ 07:58 AM).]

AuthorReplies:
heraldudb
Skirmisher
posted 11-05-05 00:47 AM EDT (US)     201 / 243       
accordingly i'm having that trouble also. followed timoo's instruction on how to install the full retail up to the exact location of the game's folder which is:
C:\Program Files\Microsoft Games\Age Of Empires 3\Age of Empires III

the game ran. but the PATCH, did it exactly also EXCEPT its not working:
(please let me know how i got it wrong)
got into regedit
on regedit, i looked for... OIC!!!

got it!

bro, place the SetupPath (with the same path above on data value) on "HKEY_LOCAL_MACHINE" and not "HKEY_USERS"!!

finally yeah!!!

btw, while you're patching it, its going to freeze somewhere but its cool, its just being shitty but it will be patched bro.

thanks everyone.

mostly thanks to mr timoo - MAN, you should be heading aoe3's technical division (or MSgames studios technical even). you have the gamer's endorsement!!!

and to you MS, you may have delivered aoe3 in shining glory, but don't forget - that shining glory is only up to the developer. to the publisher who set the rules on which os to install it to (that will be you, ms), no shining glory at all. yeah, you heard me MS, shove your publisher ass to your... well, er.. ass.

good evening gentlemen.

josjos
Skirmisher
posted 11-06-05 07:02 AM EDT (US)     202 / 243       

Quote:

Note: Once you have that done, you may also get another error about MSXML 4; if this is the case then you should install msxml4msms.exe from http://www.microsoft.com/downloads/details.aspx?FamilyID=3144b72b-b4f2-46da-b4b6-c5d7485f2b42&DisplayLa ng=en#filelist
ive done this but it puts me to where i wanna place the files. is there specific place where i place the files?

I have the same problem. I installed AOEIII, I installed d3dx9_25.dll, I downloaded msxml4msms.exe, but where do I have to place this file? I tried several locations, but all the locations I've tried, don't work. Can someone please tell me the right location to extract those files to?

Timooo
Skirmisher
posted 11-07-05 06:34 AM EDT (US)     203 / 243       
My Sincere Apologies! In my instructions on updating MSXML I gave the name of the Wrong File to download. You must download msxml.msi Not msxml4msms.exe. msxml.msi is an auto install; so once again I greatly apologize! Have fun playing AOE3. =)

(Note: I've corrected my previous installation post; and have added a new section on how to install the AOE3 1.01 Update - Goto page 7 to view my instructions.)

Also, Thank You for such kind comments heraldudb. =D I highly appreciate it! ^^

[This message has been edited by Timooo (edited 11-10-2005 @ 04:42 AM).]

jvanatta
Skirmisher
posted 11-07-05 07:10 AM EDT (US)     204 / 243       
Can anyone give me a definite yes/no as to whether you can play on ESO2 with a correctly patched version under 2000? I want to buy the game but won't bother unless it's possible.
The dateDR
Skirmisher
posted 11-12-05 09:38 PM EDT (US)     205 / 243       
TIMOO IS A FREAKIN GENIUS!!!

THANX A MILLION.

aoe3 is cool but I grew tired of it TOO fast.

STILL NOTHING WILL EVER COMPARE TO
COSSACKS: ART OF WAR !

[This message has been edited by The dateDR (edited 11-13-2005 @ 00:14 AM).]

Andre Win2k
Skirmisher
posted 11-14-05 07:41 PM EDT (US)     206 / 243       
Hey all, game loads for me, thanks to the instructions in this thread, but when I try to go online, it says "ESO Does not support your game version" or somthing along those lines. Has anyone else had this issue? I've read the majority of posts here, maybe I missed a step or somthing. I have sucessfully patched the game. (my registry tells me I'm running 1.01) Anyone have any suggestions?

thanks in advance, this site's been a great help for those of us who don't want to waste our money on XP with Vista just around the corner.

tster123
Skirmisher
posted 11-14-05 08:03 PM EDT (US)     207 / 243       
that is a common problem with ESO that has been happening to a lot of people (win XP and win 2000)
jvanatta
Skirmisher
posted 11-14-05 08:43 PM EDT (US)     208 / 243       
ES's lack of any commentary about Win2000 and ESO2 indicates to me that they're deliberately blocking it and don't want to admit it. (Yes I know 2K isn't supported but theres a big difference between not supporting and purposefully blocking something).

Unless someone wants to indicate otherwise so I can go buy the game?

Andre Win2k
Skirmisher
posted 11-16-05 05:21 PM EDT (US)     209 / 243       
well, I still can't get online, but I've been reading that they've been working on it. If I do get online, I'll come back here and post, so you can get the game. (If I can't, I'll be p*ssed off, cause I bought the game for its online play)

Ok, here's my verdict. With windows 2000, following all the instructions in this thread, I am unable to play online via ESO <--(the standard way) I now get an error message that says I have a gimpy install, so I can't play online. I tried re-installing, and re-patching, however, I had the same end result: I was unable to connect. ESO must scan your computer before it allows you to connect. I have no idea how to bypass this, or hide my OS version from them. I am fresh out of ideas for now. Don't hold your breath, waiting for a solution. and don't run out and buy this game if you have windows 2000 and want to play online.

[This message has been edited by Andre Win2k (edited 11-17-2005 @ 10:42 PM).]

fzwallace
Skirmisher
posted 11-19-05 05:51 PM EDT (US)     210 / 243       
Hi all, I just bought the AoE3 yesterday, apparently it kept on saying im running on wrong version.

So I went and hunted down a way to make it work on Windows 2000. So thankfully found this and now still encounter problem when trying to install the game.

I Did exactly the way what Timmo did, going cmd , drive:/setup /a then it autoruns the game.. so I put the location for the game to be installed then i clicked on "install" then it just frozed.

Any suggestions?

jvanatta
Skirmisher
posted 11-20-05 06:46 PM EDT (US)     211 / 243       
Thanks Andre, I suspected as much. Time to find something else to play instead.
Austin2174
Skirmisher
posted 11-28-05 07:18 PM EDT (US)     212 / 243       
Thanks everyone for all your help. I've read through this entire set of posts regarding installing AOE on Windows 2k. I tried the two different workarounds I found here, and got the trial installed that way. Unfortunately, when I went to run the trial, I got an error message saying that it was unable to find splash resources. I could find no information on this site or any others mentioning this specific error.

So I cleaned everything up, got rid of all the files and tried the last resort option mentioned here. I had a friend who has XP copy the installed files for the full game to a dvd. I then copied the files to my hard drive and when I attempted to start the game, I got the following message:

"Cannot find the file splash.exe (or one of its components). Make sure the path and filename are correct and that all required libraries are available."

I verified that the file splash.exe does exist and it is in the Age of Empires III folder.

I searched for hours trying to find an answer to this error and came up with nothing. Does anyone have a suggestion please? Thanks again.

The Bob
Skirmisher
posted 11-29-05 01:39 AM EDT (US)     213 / 243       
Haven't tested this out but if it's on MegaGames it should work.

If it's already been posted then whatever..

http://www.megagames.com/cgi/download/download.cgi?action=search&category=cracks&search=AGE.OF.EMPIRES.3.WIN2KINSTALLPATCH.ANDREW.FIX.ZIP

Enjoy.

[This message has been edited by The Bob (edited 11-29-2005 @ 03:40 AM).]

jaafit
Skirmisher
posted 11-29-05 03:23 AM EDT (US)     214 / 243       
Umm, how is that link related to win2000? oh well. thanks, have fun in banville...

agecommunity quote of the month Ok i have payed for this game for al my moneythat i get in a month so when i go online isee these 9 year old kids that beat me that have played for 2 weeks and i have played since release of vanilla so im pretty pissed of that es dosent want to do anything about the balance of the game.
The Bob
Skirmisher
posted 11-29-05 03:38 AM EDT (US)     215 / 243       
Maybe if you "opened" it and "looked" at the file called "Age of Empires 3 Win2K Install Patch" then you would know. Quite frankly I don't care about what else is on the site, but if it pains you so greatly I guess I'll give a direct link; thus avoiding any material that this site wouldn't appreciate.

Cretin.

[This message has been edited by The Bob (edited 11-29-2005 @ 03:40 AM).]

Petter156
Skirmisher
posted 12-08-05 09:43 AM EDT (US)     216 / 243       
Im not sure if this is an old post or not but I wanted to post here first instead of making a new thread.

AOE3 was one the games I was looking forward too most this year... well too bad, I run Windows 2000. I wish ES wouldnt have let me down, I wish Microsofts greed and disregard of their consumers would have limits. But the world is such a cold and cruel place.

Oh well... enough rambling - heres the deal:

Like I said I use Windows 2000 (by choice) and the trial version of Age Of Empires III wont run when installed normally. So I was pretty happy when I found this thread yesterday.
Using the method McGyver2k posted (page 7 I think) I tried to install the demo (first v1.1 then the first version of the demo). The installer rolled along until it popped up an InstallShield box telling me "1607: Unable to install InstallShield scripting language". Well bummer. Do you people know of any way to get the demo to run/install? Has anyone else experinced this. Do I need to install the "InstallShield scripting language" manually somehow? Is there any hope left?

Thanks in advance for any advice you might be able to give me.

Corwin1980
Skirmisher
posted 12-09-05 04:04 AM EDT (US)     217 / 243       
I've also tried to install the game on Win2k following the above mentionned procedure but I still get the MSXML4.0 error message when I want to launch the game even after I downloaded and installed msxml.msi.
Anyone have a stroke of genius about this?
I Let You Go
Skirmisher
posted 12-09-05 04:46 AM EDT (US)     218 / 243       
er. is there an apple version or something? i have a friend with an apple laptop or itop or book or whatever is now trendy to call it. and i want to play him over lan.
ichwill
Skirmisher
posted 12-13-05 12:28 PM EDT (US)     219 / 243       
Hello all,

First of all thanks for everything. I am on win2000, followed the whole procedure but it still doesn't work.
I've got the icon on my desk but when launching it it says "the application did not manage to initialize properly (0xc000001d). click on "ok" to cancel application" though I updated the MXML stuff
I am so looking forward to test this demo prior to buy the game.
Can someone help plz, I guess I am so close to it...

Many thanks in advance

Olarad
Skirmisher
posted 12-13-05 01:07 PM EDT (US)     220 / 243       
This is why I believe AOE3 does not support Windows 2000.

Microsoft is in business to make money. Windows 2000 is updateable with a pirated copy, windows xp is not.

Not 1 single pc sold from a retail store(best buy circuit city etc.)was sold with Windows 2000 installed on it. It had to be special ordered. Windows 2000 was mainly for professional users, and windows ME was released to be preinstalled for retail computers. Of course ME was complete crap, but that is not my point right now.

My point is, I would say AT LEAST half of the posters in this thread have an illegal copy of windows 2000. I surmise this because you are complaining about the cost of XP home edition, which is WAY cheaper than windows 2000 PRO ever was, so I doubt you legally purchased it.

Now I am not sitting on my high horse telling everyone is bad for having pirated software, I have been guilty of it myself. However, you shouldn't bitch at Microsoft for trying to stop it.

Petter156
Skirmisher
posted 12-13-05 02:17 PM EDT (US)     221 / 243       
Well Im a part of the half that paid for the OS. And if you want I can show you the receipt.

Now I just want to BUMP this one more time and ask for help... if anyone has an idea on how to get the demo to work after receiving the kind of errors I received (see a few posts up), I would be greatly happy. I would at least like to try this game out.

ichwill
Skirmisher
posted 12-19-05 12:19 PM EDT (US)     222 / 243       
Well I definitively guess AOE3 isn't for me. I would have loved trying this game but I am not ready to buy a dedicated upgraded computer for that.
I tried everything presented in this topic and nothing worked on my PC.
I installed XP then and it appears that my 1.33 processor does not support the advanced functions required by AOE.
Now, I have a total bugged computer (lost all the stability I had on 2000... for nothing)
Olarad, just to confirm I have a legal copy of XP and, sorry, but I will never applause Microsoft for this policy. Ensemble studios will loose many opportunities of sales having been conducted by Microsoft to only allow it to run on Win XP.

I wish you all to have fun on this game that seems so brilliant and wish Microsoft and Ensemble Studios all the worst for the future.

I am going back to warcraft3 as Blizzard policy is far more open and customer oriented than ES' one. And Blizzard is making much more money. Any relationships?...

just_another_one
Skirmisher
posted 12-19-05 02:21 PM EDT (US)     223 / 243       
Im gonna be blunt, it may have been said earlier but if it has it could probably do with also being down here.

Is it possible to run Age of Empires 3 (full version) on Windows 2000.
If I find a computer with XP on it and network it with the other '2000 computer' can I transfer the installed files on to the '2000 computer' and then run it.

If so is there any problems with registery files etc?

vbscript2
Skirmisher
posted 12-19-05 03:58 PM EDT (US)     224 / 243       
first: no, you can't run AoE 3 on an Apple computer and that was off topic. Actually, you can't run much of anything on an Apple.

second: Why would you try to install AoE 3 on a 1.33 GHz box when the minimum is about twice that (assuming it's not a Pentium M.)

third: Like was said earlier, very few people have legal copies of Win 2K Pro for their home, although I am aware of a few cases. However, in most of those cases, the computer is too old to run AoE 3 anyway.

fourth: In order to officially support an operating system, extensive testing would have to be conducted on it. Since there are few people running Win 2K Pro legally on PCs good enough to run AoE 3 anyway, the cost to support 2K would probably be greater than the revenue gained from it.

[This message has been edited by vbscript2 (edited 12-19-2005 @ 04:00 PM).]

just_another_one
Skirmisher
posted 12-20-05 05:33 AM EDT (US)     225 / 243       
It is possible to run and install AOE3 on Win2k, I cant be bothered to go through it again but I have put another topic up about it.

It works absoloutley fine

« Previous Page  1 ··· 7 8 9 10  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Age of Empires III Heaven | HeavenGames