You must be logged in to post messages.
Please login or register

General Discussions
Moderated by Maffia, LordKivlov, JimXIX

Hop to:    
Welcome! You are not logged in. Please Login or Register.243 replies
Age of Empires III Heaven » Forums » General Discussions » Windows 2000
Topic Subject:Windows 2000
« Previous Page  1 ··· 8 9 10  Next Page »
posted 09-07-05 07:03 PM EDT (US)         
"Age of Empires III Trial requires Windows XP or later" - well, okay, except it's lying.

I use Windows 2000, so the installer refuses to run - but I can install on a spare machine that's running XP, then copy the installed files, and it appears to work perfectly well on 2K.

As far as I can see, there's no reason why the installer should be telling me to upgrade. An updated version of the demo, without this bug, would be appreciated. I shouldn't have to mess around so much just to run a game, and if it's not fixed in the retail version, ES has lost at least one sale.

Update: If you have encountered this problem, see post #111 for a way to install the game.

[This message has been edited by Ykkrosh (edited 09-09-2005 @ 07:58 AM).]

posted 12-20-05 12:13 PM EDT (US)     226 / 243       
Well OK then... I guess I might be able to play the game anyway. Does this mean that IŽll rush out to the store and buy it? Hell no. Most likely a friend of mine will be able to borrow it to me, if not... weŽll see...

Windows 2000 isnŽt old enough as an OS to not be supported and my PC is up to date enough to run the game. IMHO, you should have made the effort.

ES, youŽve made the decission not to support me as a fan of the series... IŽm making the decission not to support you.
Hope your Microsoft-money keeps you warm at night - my money wonŽt.

posted 12-21-05 11:43 AM EDT (US)     227 / 243       
Anybody know why I keep on getting
this error when lauching the demo?

ywing pilot
posted 12-21-05 08:44 PM EDT (US)     228 / 243       
"Go to the 1.0 folder. Right click and click New->String. Name the string "SetupPath"(without the quotes) and set the value to the path of the game."

Nothing happens. Same error.

I made a new string under 1.0, named it "SetupPath", and set it to the exact location, but still no.

~The Evil Weasel
posted 12-24-05 08:03 PM EDT (US)     229 / 243       
my game was saying the same error

have you any solution?

posted 12-26-05 05:07 AM EDT (US)     230 / 243       
this is my problem when i try to update it(the string is correct) There is a problem with your installation. You may need to reinstall the game to fix it.

[This message has been edited by danny411 (edited 12-26-2005 @ 05:08 AM).]

posted 12-28-05 05:32 PM EDT (US)     231 / 243       
Damn! reinstall the game? are you sure about it?
posted 12-28-05 11:22 PM EDT (US)     232 / 243       
ok i bought the cheap upgrade for xp

Now how do i upgrade to xp using the win98 upgrade --i have win 2k installed ?


Der Drakken
posted 12-30-05 01:51 PM EDT (US)     233 / 243       
To Install the 1.0 to 1.03 patch for Windows 2000

-Follow Timooo's steps 1-8 on installing the 1.01 update
(you won't need to install the 1.01 update though, step 9)
-Download the Patch file age3-10to103-english.exe
-Don't run the self-executing zip file. Extract the files inside with WinZip
-Run the unzipped file aoe3-10to103-english.exe (note: similar name to the zip file...make sure you run aoe3...exe)
-Done and you can play SP on the large maps

posted 01-01-06 02:07 PM EDT (US)     234 / 243       
I do not like the implication that win2000 users are pirates!

Why would MS have updated win2000 to be able to play game sin the first place? That's right because there was a cry for an update (dx compatibility).
Why do games list themselves as being win2000 compatible if gamers do not have win2k?

And lastly, I don't know about the big guys..but at the places i have bought custom computers, you were allowed to choose your O/S.

And the obvious choice for me was win 2000 (bought just after service pack 2 fixed things)
Anyways, the main reason for my posting now is to say

cmd/// d:setup /a did not work for me.
After i put in the second prompted me for disk 1..and complained it was missing a cab file. I had to abort the install process.

Heh. It is definately getting harder to install games between win2k losing support and my drives being incompatible with the latest draconian copy protections.
I know i would not have these problems if i went warez.

My big problem is i am unsure of what to do. I am waiting for Vista to upgrade..but that might not be until next fall.
I don't see why i should be forced to buy winXP only to upgrade in a few months.

But i now have 5 games i have bought but can't play

posted 01-01-06 02:49 PM EDT (US)     235 / 243       

Take a look at this thread:,27699,30,10

I found another way of installing the game. It is a difficult method but worked well for me and allows me to do everything except play online.

posted 01-02-06 07:17 AM EDT (US)     236 / 243       
After many inquiries I made on the web it appears that I cannot install the game because my processor does not support advanced instructions (SSE). Indeed I have an AMD Athlon Thunderbird (1.33 GHZ)which seems to be the latest series from AMD which do not have this (please don't ask for further precisions I am not an IT expert...)
I just wanted to underline that because it may help some of you who, like me, are trying to make this f.... game run.
Goodbye all - snif.......

Memo: I moved from Win2k to XP, then tried to overclock my PC (game requiring 1.4Ghz, my processor is 1.33GHZ) but it's definitively not for me. My big thanks are going to Microsoft and ES.

posted 01-02-06 01:32 PM EDT (US)     237 / 243       
Yeah Itchwill, you're pretty much stuck upgrading your hardware if you want to play this game. Workarounds for the OS are one thing, can't get around the hardware reqs though.
posted 01-04-06 04:40 PM EDT (US)     238 / 243       
Sorry if this was ever asked before, but I'm having a problem getting online with after installing it on Win 2k. It says, "ESO can not support your game" or something close to that when I click ESO to get online. I could really use some help.
posted 01-04-06 05:04 PM EDT (US)     239 / 243       
@ Flayvin

Unfortunately, I think they do an OS check when you try to connect to ESO, so it seems we may well be out of luck..

"Build a man a fire, and you warm him for a day. Set a man on fire, and you warm him for the rest of his life." -Chinese proverb

"If MacGyver and Jack Bauer were in a fight, Chuck Norris would win."

posted 01-14-06 08:30 PM EDT (US)     240 / 243       
POsted by Hollo W on

Actually it works smoothly on win 2k, it just needs a reach around to install it then its all fine. I didn't invent the process, i just adapted it to make the full game work, so ill quote who already thought of this way for the demo, modifying whats needed:

Macgyver2k has found an easy way to install the Age 3 Demo on Windows 2000:

1. Put the original cd into the cd drive (i'll use g
2. Start -> run -> cmd
3. in g:\ Type: setup.exe /a
4. Click next, then the installer will ask for a network path, simply type in the path you want to install the game to ( e.g. c:\games\AOE3)
5. Click Install ( it seems se program does nothing, but the installation is in progrss - maybe takes some minutes )
6. And then finish

Hope it can help, its an awesome game, but i bought it without looking if it worked for win2k (so far its the only game i seen with this problem) so i was kinda disappointed to have to spend even more money on a new os.


ywing pilot
posted 01-15-06 12:18 PM EDT (US)     241 / 243       
"-Follow Timooo's steps 1-8 on installing the 1.01 update"

The whole point is that steps one-eight DON'T WORK!

~The Evil Weasel
posted 02-16-06 07:40 PM EDT (US)     242 / 243       
okay im going to be straight forward in saying im pretty new to this whole computer installing thing, but i followed the steps and installed AOE3 but i can get it to run, i dont know how to setup the shortcut mentioned on pg 7 of this forum. can someone please put me through a detailed guide to run it after installing?
posted 02-18-06 02:28 PM EDT (US)     243 / 243       
Timooo is da bomb
thank you man, game runs smooth and clear on 2k, no probs, even updated to 1.04


P.S : XP sux ^_^

[This message has been edited by Tzadkiel (edited 02-18-2006 @ 02:54 PM).]

« Previous Page  1 ··· 8 9 10  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Age of Empires III Heaven | HeavenGames