You must be logged in to post messages.
Please login or register

General Discussions
Moderated by Maffia, LordKivlov, JimXIX

Hop to:    
Welcome! You are not logged in. Please Login or Register.386 replies
Age of Empires III Heaven » Forums » General Discussions » Bug Reporting for the Age of Empires 3 Demo
Topic Subject:Bug Reporting for the Age of Empires 3 Demo
« Previous Page  1 ··· 10 ··· 14 15 16  Next Page »
posted 09-07-05 10:58 PM EDT (US)         
We have created a new e-mail address to collect your bugs. If you encounter anything please send an e-mail to If you are using a hotmail e-mail address it may bounce your e-mail.

Be sure to include as much information as possible about your system, any logs you received as well as error messages. If you provide reproduction steps that would also be helpful.


Common fixes for most problems

1.Make sure your system supports the minimum requirements.

2.Make sure that your video card and sound drivers are updated.

3.When you install be sure to turn off any antivirus software.

4.Make sure the game is not blocked by any security software.


If you are having problems starting the demo try these four fixes.

1. Open your My Documents\My Games\Age of Empires 3\Startup folder

2. Create a user.cfg file

3. Add the line +nointrocinematics save and exit

4. Play the game

--- or ---

1. Turn off anti-aliasing

--- or ---

If you have a wide screen monitor

1. Open NewProfile.xml

2. Find the line optiongrfxres

3. Change the resolution to 1024 x 768

--- or ---

1. Download the latest version of Microsoft XML (MSXML 4 SP2)

2. You can download it here


If you are experiencing sound problems be sure to include the Age3log.txt and the DXDiag output.

To get DXDiag output

1. Go to Start

2. Click on run and type DXDiag and hit enter

3. Click on the sound tab

4. Copy the informatiuon from there and include it in a e-mail


We are tracking the sound issue right now. Thanks to everyone who sent in their information.

A possible fix for the sound issue is to turn off hardware acceleration. This may only work on some hardware.

1. Go to Start and Run

2. Type in DXDiag and hit enter

3. Go to the sound tab and move the hardware sound accerlation bar all the way to the left

4. Click Exit and restart the computer


[This message has been edited by SuperTr00pers (edited 09-09-2005 @ 03:49 PM).]

Crue Knight
Divine Favor
(id: Crusader Knight)
posted 10-12-05 04:52 PM EDT (US)     376 / 386       


When playing Spanish, I cannot queue up multiple tasks for the villagers using the shift key.
When I assigned the second task (with the shift key) the villager ignores the first task and goes to perform the second task.
There is also a similar problem with the British villagers.
If I have a villager that is already performing a task, when I give him a new task, sometimes the villager ignores that new command, and I have to send him to any location on the map before I can give him a new task.
Also, many times if I queue up 2 tasks for the villager, he would not perform the second task once he is done with the first one,

Yes same here.

Here are some problems I encountered:

-Another bug is that priests walk side ways (faced up).
The only time they are upright is when healing.

-The anti-artilery artilery (forgot the name but it's the yellow cannon) does not move or actually "glides" instead of moving. It doesn't even move when unloading, although it still fires but in the same position when it first was created.

-The Fluyt ship doesn't "spark" when firing.

-Units won't delete.

-Unit's sometimes wont complete buildings (like a trde post or something)


Ex mod on: Spore - HG - RoN - RoL - N:TW
Check out my: DeviantArt - Steam

[This message has been edited by Crusader Knight (edited 10-12-2005 @ 04:57 PM).]

Mongol horse man
posted 10-12-05 06:17 PM EDT (US)     377 / 386       
In the demo you can't delete units in the demo for the other stuff I have no clue.

(O.o )
(> < )Say hi to the bunny!
"Once they have vaginas, they'll take over the world.-Cy Marlayne on the subject of robots.
posted 10-13-05 11:14 PM EDT (US)     378 / 386       
Hey, does anyone know how to rotate the camera in the demo? Thanks!
posted 10-14-05 00:28 AM EDT (US)     379 / 386       
To rotate the camera, hold down Ctrl and the Left or Right arrow. To zoom, move your mouse scroller or use + and -.

Forgive and forget, just don't forget to forgive.~Comador02


[This message has been edited by God (edited 11-19-2120 @ 2:38 PM).]

Crue Knight
Divine Favor
(id: Crusader Knight)
posted 10-14-05 01:20 AM EDT (US)     380 / 386       
Oh I just found that out!!! It's a pretty neat function.


Ex mod on: Spore - HG - RoN - RoL - N:TW
Check out my: DeviantArt - Steam
posted 10-14-05 08:39 AM EDT (US)     381 / 386       
When I first installed aoe3 demo, it was working perfectly, but after about a week, when I open aoe3 demo it says :
Initialisation failed
direct 3d initialization failed. possible causes:
old or corrupted driver. ---------------- I updated my drivers
direct3d improperly installed. ------------------ I re installed directx 9.0
hardware acceleration disabled. -------------------- ?????
starting the application with the workstation locked. ----------------???

ive got intel extreme graphics and I reinstalled aoe3 demo
And when i check the log file it says PreGame 2112: nvCPL is unavailable.
what should I do can you please help me.

posted 10-17-05 10:59 AM EDT (US)     382 / 386       
for the ones where the music and sound crashes/repeats after 10-15 minutes, the solution:

I had this problem and tried to solve this problem by turning out the hardware sound acceleration, downloading drivers and audio packs.

But none of this helped. But i found the solution, well for me and i saw others had the problem.

Go to program files/ microsoft games/ aoe3 trial / sound / music/ standard.

There you will find some songs. Lissen to them all. You will notice that you never heard some of these songs. Remove those from the map(the one you never heard before).

Somehow this solves the sound problem, i dont know why.
But aoe3 will still use ram when you stop the game. If you want to solve that you need to remove all songs out of the map, but that means no songs while playing.

posted 10-17-05 07:16 PM EDT (US)     383 / 386       
RFE: see,25335,0,10for a discussion on adding an indicator (in addition to the tool-tip) that a mill or plantation is full.
Ferdinand Gwonch
posted 10-17-05 08:29 PM EDT (US)     384 / 386       
british female settlers speak "wrisht"(?) instead of "build", while male ones speak "build" normally
is this a bug?

posted 10-23-05 11:24 AM EDT (US)     385 / 386       
I've played the demo quite a bit, I dont seem to have many of the problems you Uber PC people have. My specs are:

Athlon XP 2400+
aTi Radeon 9200se 128 MB
onBoard Realtek AC97 Audio
Gigabyte GA-<wierdnumbers> Motherboard
256 Mb Ram
Windows XP

I have only got the Iroquois Tomahawk not appering bug
also, the physics never worked . . .

Somehow, the problem has solved itself and my physics work fine
Iroquois tomahawk is visible

Only wierd bugs are the pirate sliding (skating,Skiing,whatever..) and guardians healing themselves

Oh and also, at a native indian trade post, in some place, You guys at ES have forgotten to put the hair for the Thumbnail image of the native. It looks kinda wierd, the dude has a gray/white patch where there should be hair . . .

Otherwise, My sounds are fine and no other problems

The Anti-Aliasing does not affect sytem performance whether on or off, but the AA effect is visible. Kinda cool but strange.

AND Grunt, the link to your 'uber comics of doom' (cow.whatever.whetever) does not work..

Thanx y'all

Ingo van Thiel
posted 10-23-05 05:09 PM EDT (US)     386 / 386       
Played demo version 1.1 again tonight (vastly improved since 1.0 IMHO ), and I think I noticed a bug concerning the canoes: I tried to attack an enemy caravel, and an enemy harbor with canoes (no one was garrisoned in them). When the canoes came near the target, the graphic of the rifleman in the canoe changed to a warrior holding a torch, but he did not wield/throw it. This happened with all four canoes I had: They stood still before their target, holding up their torches, and neither the enemy caravel nor the dock received any damage. After 10-15 seconds, the canoes got sunk by the caravel without dealing any damage to it.

Is this a reproducable bug, or am I missing something about the attack function of canoes? If this is a bug, is this fixed in the full version?


[This message has been edited by Ingo van Thiel (edited 10-23-2005 @ 05:11 PM).]

« Previous Page  1 ··· 10 ··· 14 15 16  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Age of Empires III Heaven | HeavenGames